界面说明-工程编辑-菜单栏

“菜单栏”位于界面最上方,共有4个菜单,选择菜单中的命令可以执行相应的操作。菜单中图标为灰色表示功能当前不可用。


文件

“文件”菜单包括:保存工程,另存为,自动保存,生成压缩包,分享,校验。



保存工程 点击“保存工程”,可以将当前工程保存在云平台,界面右上角会弹出“保存成功”的消息,下次登录可以打开工程,继续编辑。支持快捷键“Ctrl+s”保存工程。 另存为 点击“另存为”,可以将工程另存为一份副本,重新定义工程名与作者。用户可以根据需求选择与原工程不同的分辨率,并同时计算相应的图层、控件尺寸在水平和竖直方向的拉伸比例。举例来说,原工程分辨率为800×600,在另存为时如果选择分辨率为800×400,则需要设置高度比为1:1.5。



自动保存 点击“自动保存”,在弹出的对话框中可以选择是否定时自动保存工程,防止编辑中用户未保存的工程因为窗口关闭等问题丢失。用户可选每10、30、60分钟进行自行保存,不选择默认为不自动保存。



生成压缩包 点击“生成压缩包”,在弹出的对话框中选择生成工程包的类型。可选类型有:常规、压缩、本地、模板、预估文件大小。



压缩工程包,开机动画等控件会在一体化软件烧写上板时进行再次压缩,文件占用存储空间较小。压缩类型会降低屏幕显示效果。

本地工程包,可以在本地版IDE软件的文件夹下,将工程包复制到工程列表中,或拖曳到本地版个人中心的工程列表中,实现本地和在线编辑的转换。

模板格式会将该工程保存为模板,在其他工程编辑时导入。

预估文件大小功能不会生产工程包,仅在界面右上角弹出默认格式下生成工程包的大小,用户可根据预估值,决定是否采用压缩格式。

确认生成工程后,会在界面右上角弹出“生成成功”的消息,同时弹出保存打包文件的对话框,选择保存地址,即可以生成本地工程包。

分享 点击“分享”,会在界面的右上角弹出分享工程的消息,点击开启分享后,会出现分享路径和密码,分享发起者将路径和密码共享给需要分享的人后,需要分享的人在浏览器输入链接,输入密码后就可以编辑工程。



但是当此工程正在被其他编辑,为了保证工程状态的一致性,同一时间,只允许一位用户通过分享的方式对工程进行编辑,其他用户无法进入该工程,需要主动联系当前的操作人员。 需要加以区别的是:同一时间一个账号在两地同时登陆不会产生冲突,但工程内容以后保存者为准。





校验

点击“校验”,可以校验本地压缩包是否是IDE编辑直接生成的文件包,在弹出的对话框中上传需要校验的压缩包,根据工程包内涵全部文件生成的哈希值进行校验,即可显示文件合法性。




编辑

“编辑”菜单包括:添加画布、添加子画布、撤销、重做、复制、粘贴、添加控件、剪切、删除、排序、全选、查找、清除、动作可视化、运行。支持常见的“Ctrl+X”快捷键。



选中一个页面,点击“添加画布”,可以在当前页面添加画布,该画布上默认有一个子画布。

选中一个画布,点击“添加子画布”,可以在当前画布添加一个子画布。

点击“撤销”,可以取消前一步操作。

点击“重做”,可以恢复前一步被撤销的操作。

点击“删除”,可以删除当前选中的页面、画布、子画布或控件。

选中一个子画布,点击“添加控件”,会出现下拉的控件列表,点击列表中的控件图标,可以在当前图层添加一个该控件,同时在界面右上角弹出“添加widget成功”的消息。每种控件的使用方法将在“高阶设计-控件说明”部分详细介绍。

点击“复制”、“剪切”、“粘贴”,分别可以复制、剪切、粘贴当前选中对象,该对象可以是画布、子画布或控件。

点击“排序”,会出现下拉列表,可以对当前选中对象进行“上移一层”、“下移一层”、“移至顶层”、“移至底层”操作,改变对象在页面中的排列顺序。

点击“全选”,可以选中全部画布或控件。这取决于“图层列表”中的当前选中对象:如果图层列表中当前选中的是页面或画布,则“全选功能”会选中所有画布;如果当前选中的是子画布或控件,则“全选功能”会选中该图层中的所有控件。

点击“查找”,在下拉文本框输入要查找的页面、画布、子画布或控件名称,按回车键确定,可以查找到工程中所有同名内容,点击“向上”、“向下”图标可以依次选中查找到的内容。注意:需要输入完整的名称,暂不支持模糊查找功能。

点击“清除”,可以批量删除画布或控件。与“全选功能”类似,如果图层列表中当前选中的是页面或画布,则会清除所有画布;如果当前选中的是子画布或控件,则会清除该子画布中的所有控件。

点击“动作可视化”,进入动作分析界面。点击“分析”,出现当前界面的动作时序图,体现不同元素、tag、计时器(timer)、动作和指令的时序动作,分析图可下载到本地,方便用户对界面逻辑进行分析。



点击“运行”,会进入运行调试界面,可以对页面上的所有控件进行整体调试,这部分将在“运行调试”部分详细介绍。


视图

“视图”菜单可以选择不同的界面视图效果,是否显示辅助线和模具框。 点击标尺后显示或隐藏标尺,从标尺拖动水平线、垂直线可定位目标。 点击模具框后显示或隐藏模具框,用于预览界面在模具中的样子。用户可设置模具框名称、位置和宽高。(坐标X、Y为模具框左顶点的坐标。)也可以直接上传模具框图片。




帮助

“帮助”菜单包括:新手引导、文档、下载。



新手引导

“新手引导”分为模块介绍和新手教程,用户可根据需要学习入门IDE。 在IDE界面中,有多处悬停的功能介绍图标,点击阅读相应的详细说明。



文档

点击“文档”,进入IDE说明文档,详细介绍IDE功能和使用方法。适合用户系统性学习了解。

下载

点击“下载”,进入下载界面,用户可以下载本地版IDE软件,支持离线状态制作界面。



本地版IDE与网页版IDE之间可以共享工程,具体在本地上传部分进行介绍。 解压压缩包,点击“速显微AHMI-IDE”应用程序,运行本地版IDE。

本地版IDE界面如下:

桌面版生成文件存储位置与内容

AHMI IDE桌面版保存的工程存储在:速显微AHMI-IDE/package.nw/localproject/路径下,每个工程有一个文件夹,保存的文件夹名为一串数字。工程目录下有:resources、project.json和thumbnail。resources为工程中所有资源,project.json为控制文件,thumbnail为工程在个人中心的图标。


results matching ""

    No results matching ""